[ 0.1.6: in progress ]

2003-09-16: quick-and-dirty patch against VeriSign sitefinder: any domain
with IN A to 62.94.110.11 is rejected as nonexistent.

2003-09-05: fix descriptor leak.

2003-09-02: feature: hosts with MXes to 127.0.0.1 or 0.0.0.0 considered
invalid and rejected.

2003-09-02: bugfix: time compare sign around connect_timed()

Config added.

[ 0.1.5: 18 Jul 2003 ]

Various bugs fixed, including CPU and memory hogging ones.

When rejecting sender address, detailed description is returned why
it was rejected (including MXer name, IP address, and reply text).

An external map is supported for specifying addresses not to check (with
either allow or deny). E.g.:

full:pupkin@hotmail.com			2
domain:hotmail.com			5

here value is one digit with the same role as first digit in SMTP or DSN
reply codes: 2 - accept, 4 - transient reject, 5 - permanent reject.

Compiled map could be made with makemap utility from sendmail:
makemap hash /etc/mail/verify_sender_map.db </etc/mail/verify_sender_map
It should have hash type of the same BerkeleyDB version as used in
daemon and test program, and be named using full name (not excluding
trailing ".db" if any) using -m, e.g.:
verify_sender -m /etc/mail/verify_sender_map.db -p inet:3330@127.0.0.1
